re = /(?:^|\,{1,})(foobar)(?:$|\,{1,})/
str = 'foobar,sdf,sdffoobar,foobar,foobarads,foobar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end