using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?P<user>[^:@\/]+)@)?(?P<host>[^:\/]+):(?P<path>.+?)(?:\.git)?\/?$";
string input = @"user@host:path/to/git/repo.git/
user@host:path/to/git/repo.git
user@host:/path/to/git/repo
host:/path/to/git/repo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}