re = /^(?:(?P<user>[^:@\/]+)@)?(?P<host>[^:\/]+):(?P<path>.+?)(?:\.git)?\/?$/m
str = 'user@host:path/to/git/repo.git/
user@host:path/to/git/repo.git
user@host:/path/to/git/repo
host:/path/to/git/repo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end