re = /\((.*?)\)/m
str = '(need to capture including brackets) ignore this
(ignore this completely)?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end