#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxJ)(?:^\s*" & @CRLF & _
" (?<name>[\w-]+\.[\w-.]*?)\.\s*" & @CRLF & _
" (?<ttl>\d+)\s*" & @CRLF & _
" (?<class>\w*)\s*" & @CRLF & _
" (?<type>\w*)" & @CRLF & _
" (?(?<=SOA)" & @CRLF & _
" \s*(?<rdata>" & @CRLF & _
" (?<mname>\S*)\.\s*" & @CRLF & _
" (?<rname>\S*)\.\s*" & @CRLF & _
" (?<serial>\d*)\s*" & @CRLF & _
" (?<refresh>\d*)\s*" & @CRLF & _
" (?<retry>\d*)\s*" & @CRLF & _
" (?<expire>\d*)\s*" & @CRLF & _
" (?<minimum>\d*)\s*" & @CRLF & _
" )\s*$" & @CRLF & _
" |" & @CRLF & _
" \s*(?<rdata>\S*)\s*$" & @CRLF & _
" )" & @CRLF & _
")"
Local $sString = "agamerica-qa.commloanservices.com." & @CRLF & _
"====================================" & @CRLF & _
"agamerica-qa.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792585 1200 180 1209600 600" & @CRLF & _
"agamerica-qa.commloanservices.com. 86400 IN NS dns002.pnc.com." & @CRLF & _
"agamerica-qa.commloanservices.com. 86400 IN NS dns001.pnc.com." & @CRLF & _
"agamerica-qa.commloanservices.com. 86400 IN NS dns000.pnc.com." & @CRLF & _
"bin.agamerica-qa.commloanservices.com. 30 IN CNAME gf0.agamerica-qa.commloanservices.com." & @CRLF & _
"gf0.agamerica-qa.commloanservices.com. 3600 IN A 161.150.124.249" & @CRLF & _
"agamerica-qa.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792585 1200 180 1209600 600" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"agamerica.commloanservices.com." & @CRLF & _
"====================================" & @CRLF & _
"agamerica.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792587 1200 180 1209600 600" & @CRLF & _
"agamerica.commloanservices.com. 86400 IN NS dns002.pnc.com." & @CRLF & _
"agamerica.commloanservices.com. 86400 IN NS dns001.pnc.com." & @CRLF & _
"agamerica.commloanservices.com. 86400 IN NS dns000.pnc.com." & @CRLF & _
"agamerica.commloanservices.com. 3600 IN A 161.150.133.216" & @CRLF & _
"bin.agamerica.commloanservices.com. 30 IN CNAME gf2.agamerica.commloanservices.com." & @CRLF & _
"gf1.agamerica.commloanservices.com. 3600 IN A 161.150.116.249" & @CRLF & _
"gf2.agamerica.commloanservices.com. 3600 IN A 161.150.40.249" & @CRLF & _
"agamerica.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792587 1200 180 1209600 600" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")