import re
regex = re.compile(r"""
(?:^\s*
(?<name>[\w-]+\.[\w-.]*?)\.\s*
(?<ttl>\d+)\s*
(?<class>\w*)\s*
(?<type>\w*)
(?(?<=SOA)
\s*(?<rdata>
(?<mname>\S*)\.\s*
(?<rname>\S*)\.\s*
(?<serial>\d*)\s*
(?<refresh>\d*)\s*
(?<retry>\d*)\s*
(?<expire>\d*)\s*
(?<minimum>\d*)\s*
)\s*$
|
\s*(?<rdata>\S*)\s*$
)
)
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("agamerica-qa.commloanservices.com.\n"
"====================================\n"
"agamerica-qa.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792585 1200 180 1209600 600\n"
"agamerica-qa.commloanservices.com. 86400 IN NS dns002.pnc.com.\n"
"agamerica-qa.commloanservices.com. 86400 IN NS dns001.pnc.com.\n"
"agamerica-qa.commloanservices.com. 86400 IN NS dns000.pnc.com.\n"
"bin.agamerica-qa.commloanservices.com. 30 IN CNAME gf0.agamerica-qa.commloanservices.com.\n"
"gf0.agamerica-qa.commloanservices.com. 3600 IN A 161.150.124.249\n"
"agamerica-qa.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792585 1200 180 1209600 600\n\n\n"
"agamerica.commloanservices.com.\n"
"====================================\n"
"agamerica.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792587 1200 180 1209600 600\n"
"agamerica.commloanservices.com. 86400 IN NS dns002.pnc.com.\n"
"agamerica.commloanservices.com. 86400 IN NS dns001.pnc.com.\n"
"agamerica.commloanservices.com. 86400 IN NS dns000.pnc.com.\n"
"agamerica.commloanservices.com. 3600 IN A 161.150.133.216\n"
"bin.agamerica.commloanservices.com. 30 IN CNAME gf2.agamerica.commloanservices.com.\n"
"gf1.agamerica.commloanservices.com. 3600 IN A 161.150.116.249\n"
"gf2.agamerica.commloanservices.com. 3600 IN A 161.150.40.249\n"
"agamerica.commloanservices.com. 3600 IN SOA dns001.pnc.com. hostmaster.pnc.com. 543792587 1200 180 1209600 600\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")