import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?Name.+?backup01\\nKind.+?\\nID?\\s+:\\s([A-Z0-9\\-]+)";
final String string = "====================================================\n"
+ "Name : backup02\n"
+ "Kind : Local\n"
+ "Mount Point : /Volumes/ext_backup01_02\n"
+ "ID : BC51C9FA-DE8A-4BA3-B23E-AEC10E9E9F69\n"
+ "> ==================================================\n"
+ "Name : backup01\n"
+ "Kind : Network\n"
+ "URL : afp://username@server02.local/backup01\n"
+ "Mount Point : /Volumes/backup01\n"
+ "ID : 009B3736-61C5-4996-B9BC-A5230BED7961\n"
+ "====================================================\n"
+ "Name : backup03\n"
+ "Kind : Network\n"
+ "URL : afp://username@server67.local/backup03\n"
+ "Mount Point : /Volumes/backup01\n"
+ "ID : 1E9A3734-33D6-1316-C9B4-B143DA35D9F2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}