import re
regex = re.compile(r"^.*?Name.+?backup01\nKind.+?\nID?\s+:\s([A-Z0-9\-]+)", flags=re.DOTALL)
test_str = ("====================================================\n"
"Name : backup02\n"
"Kind : Local\n"
"Mount Point : /Volumes/ext_backup01_02\n"
"ID : BC51C9FA-DE8A-4BA3-B23E-AEC10E9E9F69\n"
"> ==================================================\n"
"Name : backup01\n"
"Kind : Network\n"
"URL : afp://username@server02.local/backup01\n"
"Mount Point : /Volumes/backup01\n"
"ID : 009B3736-61C5-4996-B9BC-A5230BED7961\n"
"====================================================\n"
"Name : backup03\n"
"Kind : Network\n"
"URL : afp://username@server67.local/backup03\n"
"Mount Point : /Volumes/backup01\n"
"ID : 1E9A3734-33D6-1316-C9B4-B143DA35D9F2\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")