using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?azerty.*";
string substitution = @" ";
string input = @"azerty";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}