import re
regex = re.compile(r".*?azerty.*", flags=re.UNICODE | re.IGNORECASE)
test_str = "azerty"
subst = " "
result = regex.sub(subst, test_str, count=1)
if result:
print(result)