$re = '/[A-Z]{2,3}|[0-9]{4}/m';
$str = 'find ABCD1234
DTD0001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);