$re = '/\\\\+[^\"][a-zA-Z0-9]*/';
$str = 'Hello m\\u00e9 name is Mat\\u00bfQu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);