#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^id\h+"(.*)"(?:\Rid_p\h+"(.*)")?(?:\Rstr(?:\[\d])?\h*"")+$"
Local $sString = "id "text 1"" & @CRLF & _
"str """ & @CRLF & _
"" & @CRLF & _
"id "text 2"" & @CRLF & _
"str """ & @CRLF & _
"" & @CRLF & _
"id "text 3"" & @CRLF & _
"str """ & @CRLF & _
"" & @CRLF & _
"id "text 4"" & @CRLF & _
"str """ & @CRLF & _
"" & @CRLF & _
"id "text 5"" & @CRLF & _
"str """ & @CRLF & _
"" & @CRLF & _
"id "text 6"" & @CRLF & _
"id_p "text 6-2"" & @CRLF & _
"str[0] """ & @CRLF & _
"str[1] """
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")