$re = '/^id\h+"(.*)"(?:\Rid_p\h+"(.*)")?(?:\Rstr(?:\[\d])?\h*"")+$/m';
$str = 'id "text 1"
str ""
id "text 2"
str ""
id "text 3"
str ""
id "text 4"
str ""
id "text 5"
str ""
id "text 6"
id_p "text 6-2"
str[0] ""
str[1] ""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);