const regex = />[^<]+?</gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('>[^<]+?<', 'gmi')
const str = `<one> <two>abc</two> <two> def </two> </one>`;
const subst = `$1 David`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);