use strict;
my $str = '<one> <two>abc</two> <two> def </two> </one>';
my $regex = qr/>[^<]+?</mip;
my $subst = '$1 David';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";