using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([1X2])(?!\1)([1X2])(?!\2|\1)[1X2]";
string input = @"X121X2X21X1X2X2X11X112X";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}