const regex = /([1X2])(?!\1)([1X2])(?!\2|\1)[1X2]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([1X2])(?!\\1)([1X2])(?!\\2|\\1)[1X2]', '')
const str = `X121X2X21X1X2X2X11X112X`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}