package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`xxx.com\/supplier.php\?id=.*`)
var str = `xxx.com/supplier.php?id=500`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}