$re = '/xxx.com\/supplier.php\?id=.*/';
$str = 'xxx.com/supplier.php?id=500';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);