using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<lname>(?<=^)(?:.*?)(?=, )).*(?P<fname>(?<=, )(?:.*?)(?= \<)).*(?P<email>(?<=\<)(?:.*?)(?=\>))";
string input = @"Bailey, Michael <mbailey@homeadvisor.com>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}