re = /(?P<lname>(?<=^)(?:.*?)(?=, )).*(?P<fname>(?<=, )(?:.*?)(?= \<)).*(?P<email>(?<=\<)(?:.*?)(?=\>))/
str = 'Bailey, Michael <mbailey@homeadvisor.com>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end