package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b1\b`)
var str = `1,2,3,4
2,13,4
2,1,2,1,3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}