$re = '/\b1\b/';
$str = '1,2,3,4
2,13,4
2,1,2,1,3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);