package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^https?:\/\/[^\s\/$.?#].[^\s]*(\.css|\.js)((\/|\?)[^\s]*)?$`)
var str = `https://cccc/cs.css`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}