re = /^https?:\/\/[^\s\/$.?#].[^\s]*(\.css|\.js)((\/|\?)[^\s]*)?$/
str = 'https://cccc/cs.css'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end