package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)p-(?P<Country>[a-z]*)\-(?P<Channel>[a-z]*)\-(?P<Item>[a-z]*)$`)
var str = `p-fr-youtube-car`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}