re = /p-(?P<Country>[a-z]*)\-(?P<Channel>[a-z]*)\-(?P<Item>[a-z]*)$/m
str = 'p-fr-youtube-car'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end