package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z0-9\/\.\?\_]|\-([^\-]|$))+$`)
var str = `www.google.com/flights-usa
www.google.com/flights--usa`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}