$re = '/^([a-zA-Z0-9\/\.\?\_]|\-([^\-]|$))+$/m';
$str = 'www.google.com/flights-usa
www.google.com/flights--usa';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);