import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\W|^\\d|^[A-Z ]+$|^[tT]able.+|^[Ff]igure.+|^[fF][aA][Xx].+|^[Ee]mail.+|^EMAIL.+|\\.[\\w]+\\.|\\d[\\+\\-\\\\\\*\\/]\\d|[\\(\\)\\+\\-\\\\\\*\\/] [\\(\\)\\+\\-\\\\\\*\\/]";
final String string = "AL SJ \n"
+ "alias56 45 5\n"
+ "23 \n\n"
+ "table 3\n"
+ "I love my mom (YES)\n"
+ "(123)\n\n"
+ "EMAIL\n"
+ "email :\n"
+ "Fig.2.3.\n"
+ "a.b.b.\n\n"
+ "Model ES2/50/600 ALD Vacuum Technology will be operated in December 2007\n\n"
+ "International Price Ex) \\1,000,000\n\n"
+ "(1985) An almost ideal demand system for visitor expenditures, Journal of Transport Economics and Policy, Vol.19, No.2, 161-171\n\n\n"
+ "Then he gave advice to Morgenstern not to pay too much respect to the Austrian tradition and to go on with his own belief of the impossibility of forecasting\n\n"
+ "Head Office & Plant: 3-20, 1-chome, Higashisuna, Koto-ku, Tokyo 136-0074\n\n"
+ "micro-amanlysis of ther fh ehif wnf . ejf-e weew e$ kgejg ^%&%^ ekjwe843759843 iy3ty dfgmdbkjjkdg73 dg gh\n\n"
+ "This study applies the Repeated Discrete Choice Model (hereafter RDC) as one of (.\n\n"
+ ".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}