import re
regex = re.compile(r"^\W|^\d|^[A-Z ]+$|^[tT]able.+|^[Ff]igure.+|^[fF][aA][Xx].+|^[Ee]mail.+|^EMAIL.+|\.[\w]+\.|\d[\+\-\\\*\/]\d|[\(\)\+\-\\\*\/] [\(\)\+\-\\\*\/]", flags=re.MULTILINE)
test_str = ("AL SJ \n"
"alias56 45 5\n"
"23 \n\n"
"table 3\n"
"I love my mom (YES)\n"
"(123)\n\n"
"EMAIL\n"
"email :\n"
"Fig.2.3.\n"
"a.b.b.\n\n"
"Model ES2/50/600 ALD Vacuum Technology will be operated in December 2007\n\n"
"International Price Ex) \\1,000,000\n\n"
"(1985) An almost ideal demand system for visitor expenditures, Journal of Transport Economics and Policy, Vol.19, No.2, 161-171\n\n\n"
"Then he gave advice to Morgenstern not to pay too much respect to the Austrian tradition and to go on with his own belief of the impossibility of forecasting\n\n"
"Head Office & Plant: 3-20, 1-chome, Higashisuna, Koto-ku, Tokyo 136-0074\n\n"
"micro-amanlysis of ther fh ehif wnf . ejf-e weew e$ kgejg ^%&%^ ekjwe843759843 iy3ty dfgmdbkjjkdg73 dg gh\n\n"
"This study applies the Repeated Discrete Choice Model (hereafter RDC) as one of (.\n\n"
".")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")