// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\S]*)<span([^<]*)>(.*?)<\/span>([\S]*)").unwrap();
let string = "<p>Given <span class=\"label\">Butter's game, the tree counts as more than one input.</p>
<p>Given <span class=\"label\">Butter'</span>;s game, the tree counts as more than one input.</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}