using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"fcku";
string input = @"I COULD HAVE DELETED YOUR REGEX!
WHERE ARE YOU FROM?
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}