package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`fcku`)
var str = `I COULD HAVE DELETED YOUR REGEX!
WHERE ARE YOU FROM?
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}