$re = '/https?:\/\/.*\.[a-zA-Z]{2,3}/m';
$str = 'http://www.google.com
https://www.google.com
http://rahman.bz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);