re = /https?:\/\/.*\.[a-zA-Z]{2,3}/m
str = 'http://www.google.com
https://www.google.com
http://rahman.bz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end