using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(a)(?=.*(b)?)(?=.*(c)?)(?=.*(d)?)";
string input = @"a
a b
a c
a b c
a c b
a b c d
a d b c
a c d b";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}