re = /(a)(?=.*(b)?)(?=.*(c)?)(?=.*(d)?)/
str = 'a
a b
a c
a b c
a c b
a b c d
a d b c
a c d b'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end