package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\s+[A-Za-z0-9]+)+\s+$`)
var str = ` Test this stuf
Test
Test `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}