#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\+?\d{1,3}\s*-?)?\(?(?:\d{3})?\)?[- ]?\d{3}[- ]?\d{4}$"
Local $sString = "+1-541-754-3010" & @CRLF & _
"754-3010" & @CRLF & _
"(541) 754-3010" & @CRLF & _
"+1-541-754-3010" & @CRLF & _
"1-541-754-3010" & @CRLF & _
"001-541-754-3010" & @CRLF & _
"191 541 754 3010"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")