$re = '/^(?:\+?\d{1,3}\s*-?)?\(?(?:\d{3})?\)?[- ]?\d{3}[- ]?\d{4}$/m';
$str = '+1-541-754-3010
754-3010
(541) 754-3010
+1-541-754-3010
1-541-754-3010
001-541-754-3010
191 541 754 3010';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);