using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:alex|merry|david).*|(.*\/.*))$";
string input = @"publicfile/public
alex/personalfile
merry/personalfile
david/personalfile
tempasdsad/asdas
asdasdasd
alex";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}