const regex = new RegExp('^(?:(?:alex|merry|david).*|(.*\\/.*))$', 'gim')
const str = `publicfile/public
alex/personalfile
merry/personalfile
david/personalfile
tempasdsad/asdas
asdasdasd
alex`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}