using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\|\K.*?(?=\|)";
string input = @"Bacteria|Proteobacteria|Gammaproteobacteria|Pseudomonadales|Moraxellaceae|Acinetobacter|
Bacteria|Firmicutes|Bacilli|Bacillales|Bacillaceae|Bacillus|
Bacteria|Proteobacteria|Gammaproteobacteria|Pasteurellales|Pasteurellaceae|Haemophilus|
[4] ""Bacteria|Firmicutes|Bacilli|Lactobacillales|Streptococcaceae|Streptococcus|""
[5] ""Bacteria|Firmicutes|Bacilli|Lactobacillales|Streptococcaceae|Streptococcus|""
[6] ""Bacteria|Firmicutes|Bacilli|Lactobacillales|Streptococcaceae|Streptococcus|";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}