import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\|\\K.*?(?=\\|)";
final String string = "Bacteria|Proteobacteria|Gammaproteobacteria|Pseudomonadales|Moraxellaceae|Acinetobacter|\n"
+ "Bacteria|Firmicutes|Bacilli|Bacillales|Bacillaceae|Bacillus| \n"
+ "Bacteria|Proteobacteria|Gammaproteobacteria|Pasteurellales|Pasteurellaceae|Haemophilus| \n"
+ "[4] \"Bacteria|Firmicutes|Bacilli|Lactobacillales|Streptococcaceae|Streptococcus|\" \n"
+ "[5] \"Bacteria|Firmicutes|Bacilli|Lactobacillales|Streptococcaceae|Streptococcus|\" \n"
+ "[6] \"Bacteria|Firmicutes|Bacilli|Lactobacillales|Streptococcaceae|Streptococcus|";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}