#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\<<)(\d{2}/\d{2}/\d{4}\s\d{2}:\d{2}\s\D{0,3}.*?(?=\s))\s(.*?(?=>>))(>>)((?s).*?(?=<<\d{2}/\d{2}|$))"
Local $sString = "<<12/24/2015 00:00 userrrr>>" & @CRLF & _
"********** Text all char and symbols ************" & @CRLF & _
"<<12/24/2015 00:00 CET userr>>" & @CRLF & _
"Text all char and symbols" & @CRLF & _
"<<12/24/2015 00:00 GMT+1 userrrr>> Text in same line" & @CRLF & _
"<<12/24/2015 00:00 CET userrr>>" & @CRLF & _
"Text all characters and symbols" & @CRLF & _
"<<12/24/2015 00:00 GMT+1 userrrrrrr>> Text in same line" & @CRLF & _
"More Text all characters and symbols" & @CRLF & _
"<<12/24/2015 00:00 CET userrrrr>>" & @CRLF & _
"More text all characters and symbols" & @CRLF & _
"<<12/24/2015 00:00 CET userrrrrrrrrrr>>" & @CRLF & _
"More Text all characters and symbols"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")