import re
regex = re.compile(r"(\<<)(\d{2}/\d{2}/\d{4}\s\d{2}:\d{2}\s\D{0,3}.*?(?=\s))\s(.*?(?=>>))(>>)((?s).*?(?=<<\d{2}/\d{2}|$))")
test_str = ("<<12/24/2015 00:00 userrrr>>\n"
"********** Text all char and symbols ************\n"
"<<12/24/2015 00:00 CET userr>>\n"
"Text all char and symbols\n"
"<<12/24/2015 00:00 GMT+1 userrrr>> Text in same line\n"
"<<12/24/2015 00:00 CET userrr>>\n"
"Text all characters and symbols\n"
"<<12/24/2015 00:00 GMT+1 userrrrrrr>> Text in same line\n"
"More Text all characters and symbols\n"
"<<12/24/2015 00:00 CET userrrrr>>\n"
"More text all characters and symbols\n"
"<<12/24/2015 00:00 CET userrrrrrrrrrr>>\n"
"More Text all characters and symbols")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")