// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:\"(?:errorType)\"(?:[^:])*):(?:(?:[^\",])*)\"([^\"]*)"#).unwrap();
let string = "{
\"data\": null,
\"errors\": [
{
\"message\": \"Message\",
\"extensions\": {
\"errorType\": \"UNKNOWN\",
\"error_code\": \"AUTHENTICATE_USER_FALSE\"
}
},
{
\"message\": \"Message\",
\"extensions\": {
\"errorType\": \"UNAUTHENTICATED\",
\"error_code\": \"AUTHENTICATE_USER_FALSE\"
}
}
]
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}