import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[|\\G(?!\\A))([^]\"]*)\"";
final String string = "{\"firstName\":\"Gabriela\",\"id\":9153,\"language\":\"en\",\"lastName\":\"Manriquez\",\"login\":\"gmanriquez_training\",\"profileCodes\":\"[role1\",\"role2\",\"role3\",\"role4\",\"role5 ]\",\"status\":\"A\",\"statusName\":\"Active\"}\n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}